summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-17 18:05:58 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-11-22 19:44:42 +0200
commit863c66e3061118449a02e78be863d88bd877b70d (patch)
tree7ac0760fe4ed4a02f6f920a22f059ae98e10f7fe /gnu/packages/crates-io.scm
parentf1c3c08b5b5ddb218aae079b0e56d214b55d18dc (diff)
downloadguix-patches-863c66e3061118449a02e78be863d88bd877b70d.tar
guix-patches-863c66e3061118449a02e78be863d88bd877b70d.tar.gz
gnu: Add rust-shell-escape-0.1.
* gnu/packages/crates-io.scm (rust-shell-escape-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 975220fb37..6fcd0ab21a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25930,6 +25930,27 @@ picking compatible shaders.")
"This package allows easy binding to, and loading of, shared libraries.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-shell-escape-0.1
+ (package
+ (name "rust-shell-escape")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "shell-escape" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fgs1iyx3b124b7njjmhfn9q5ipmhxrafavh8mxbfl9a9zk162hp"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/sfackler/shell-escape")
+ (synopsis
+ "Escape characters that may have a special meaning in a shell")
+ (description
+ "Escape characters that may have a special meaning in a shell.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-shell-words-0.1
(package
(name "rust-shell-words")