summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-17 22:34:38 +0100
committerLeo Famulari <leo@famulari.name>2021-12-28 14:10:14 -0500
commitff25968a279c41f41df291ca3f9fecd25ee3e573 (patch)
treeafb2fb2f97259c1aee5a66420d28d3ee65f1fa7e /gnu/packages/crates-io.scm
parent4d92c989aad374e96873702d226d34dd53390730 (diff)
downloadguix-patches-ff25968a279c41f41df291ca3f9fecd25ee3e573.tar
guix-patches-ff25968a279c41f41df291ca3f9fecd25ee3e573.tar.gz
gnu: rust-packed-simd-2: Update to 0.3.6.
* gnu/packages/crates-io.scm (rust-packed-simd-2): Update to 0.3.6.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 842ee7fed1..9e5a42aa29 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35247,7 +35247,7 @@ normally prevent moving a type that has been borrowed from.")
(define-public rust-packed-simd-2-0.3
(package
(name "rust-packed-simd-2")
- (version "0.3.4")
+ (version "0.3.6")
(source
(origin
(method url-fetch)
@@ -35255,19 +35255,19 @@ normally prevent moving a type that has been borrowed from.")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "05wsm2yxxpwww6a74hi8l80qszisfar5d7whf2pd87wn5x4y0y1j"))
+ (base32 "1i8hmhsyzqsas2rhxg088mcwvzljrqhvf8lfz8b1dj6g2rkw1h3i"))
(modules '((guix build utils)))
(snippet
'(begin
;; Unpin the dependencies.
(substitute* "Cargo.toml"
- (("=0.2.52") "^0.2.52")
- (("=0.3.2") "^0.3.2"))
+ (("=0.2.73") "^0.2.73")
+ (("=0.3.23") "^0.3.23"))
#t))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; error[E0432]: unresolved import `packed_simd`
+ #:skip-build? #t
#:cargo-inputs
(("rust-cfg-if" ,rust-cfg-if-0.1)
("rust-core-arch" ,rust-core-arch-0.1)