summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-07 11:20:42 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-30 21:32:41 +0100
commit142172efb8a50a5ffe03d2c867e85511638baae9 (patch)
treeb70b6b159618ca6b523eff6ae7014eebad06c318 /gnu/packages/crates-io.scm
parent012203db1fbee26d6fa45955647e47332bd65e02 (diff)
downloadguix-patches-142172efb8a50a5ffe03d2c867e85511638baae9.tar
guix-patches-142172efb8a50a5ffe03d2c867e85511638baae9.tar.gz
gnu: Add rust-xxhash-rust-0.8.
* gnu/packages/crates-io.scm (rust-xxhash-rust-0.8): New variable.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3491226030..7d7e506db3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64671,6 +64671,26 @@ parser.")
"This package provide a utilities for quick shell scripting in Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-xxhash-rust-0.8
+ (package
+ (name "rust-xxhash-rust")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "xxhash-rust" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1v9dk6shls1rsmidf2dxdi3460bn7ingqgvn5mf7prgnxmdy2xg5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/DoumanAsh/xxhash-rust")
+ (synopsis "Implementation of xxHash in Rust")
+ (description "This package provides an implementation of the xxHash
+algorithm in Rust.")
+ (license license:boost1.0)))
+
(define-public rust-xz2-0.1
(package
(name "rust-xz2")