summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:40:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:02 +0200
commitae09a95ce2a39d14a69a0f3519a522b5c97b3eea (patch)
tree78aa567735212cca6b18e3621f13e46c3732f6ff /gnu/packages/crates-crypto.scm
parent2b30ea2c23f21858d64f1f951b63b8d04b6e0d72 (diff)
downloadguix-patches-ae09a95ce2a39d14a69a0f3519a522b5c97b3eea.tar
guix-patches-ae09a95ce2a39d14a69a0f3519a522b5c97b3eea.tar.gz
gnu: rust-cfb-mode-0.8: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-cfb-mode-0.8): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I5c2d3da0000d28a02e6a425ac9bbf011336d97af
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index b6ff123b74..738b5adba0 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1003,6 +1003,30 @@ ciphers.")
(description "Cipher Block Chaining (CBC) block cipher mode of operation.")
(license (list license:expat license:asl2.0))))
+(define-public rust-cfb-mode-0.8
+ (package
+ (name "rust-cfb-mode")
+ (version "0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "cfb-mode" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c6kd34jk4p52vr0qgn9slj6zdgmc42gfcqr6mqhmy37g138v2vk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cipher" ,rust-cipher-0.4))
+ #:cargo-development-inputs
+ (("rust-aes" ,rust-aes-0.8)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/block-modes")
+ (synopsis "Cipher Feedback (CFB) block cipher mode of operation")
+ (description "Cipher Feedback (CFB) block cipher mode of operation")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-chacha20-0.9
(package
(name "rust-chacha20")