summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 17:30:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:01 +0200
commit949963ad584e49262d4176dafa46f346d2da8bce (patch)
treec836f77cee5dcf4569a082d78f8f451af8b1605b /gnu/packages/crates-crypto.scm
parent077c0eb2cafa0feb2e5a9eea0f852b0e6385541d (diff)
downloadguix-patches-949963ad584e49262d4176dafa46f346d2da8bce.tar
guix-patches-949963ad584e49262d4176dafa46f346d2da8bce.tar.gz
gnu: rust-eax-0.5: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-eax-0.5): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I69d09b91a9e83e9a4bd32a54f95af3fb1f213510
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 1fe5441a74..14db432b6e 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1662,6 +1662,39 @@ ristretto255 and Curve25519.")
functions.")
(license (list license:expat license:asl2.0))))
+(define-public rust-eax-0.5
+ (package
+ (name "rust-eax")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "eax" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0a5cpzk577f1lw3wkk20iqvavnbdr5yzjrcglvbvk0ivj2yzlm4r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aead" ,rust-aead-0.5)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-cmac" ,rust-cmac-0.7)
+ ("rust-ctr" ,rust-ctr-0.9)
+ ("rust-subtle" ,rust-subtle-2))
+ #:cargo-development-inputs
+ (("rust-aead" ,rust-aead-0.5)
+ ("rust-aes" ,rust-aes-0.8))))
+ (home-page "https://github.com/RustCrypto/AEADs")
+ (synopsis "Pure Rust implementation of the EAX Authenticated Encryption with
+Associated Data (AEAD)")
+ (description
+ "Pure Rust implementation of the EAX Authenticated Encryption with Associated
+Data (AEAD) Cipher with optional architecture-specific hardware acceleration
+This scheme is only based on a block cipher. It uses counter mode (CTR) for
+encryption and CBC mode for generating a OMAC/CMAC/CBCMAC (all names for the
+same thing).")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-elliptic-curve-0.13
(package
(name "rust-elliptic-curve")