summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 17:26:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:01 +0200
commit7496998bc899ad56518f5126adfed12992f929b8 (patch)
treeaf39e426e7b0cf502f708318cb38ebd53dd88f2c /gnu/packages/crates-crypto.scm
parent4e84439c26ccac790df8e70d5e047a14256fee63 (diff)
downloadguix-patches-7496998bc899ad56518f5126adfed12992f929b8.tar
guix-patches-7496998bc899ad56518f5126adfed12992f929b8.tar.gz
gnu: rust-blowfish-0.9: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-blowfish-0.9): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I372c9c460b7cddaec41984f4abc8d4ee75908b18
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index fe826ac5f2..7dda3de5e1 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -790,6 +790,29 @@ based on Blake2s.")
ciphers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-blowfish-0.9
+ (package
+ (name "rust-blowfish")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "blowfish" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mw7bvj3bg5w8vh9xw9xawqh7ixk2xwsxkj34ph96b9b1z6y44p4"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-cipher" ,rust-cipher-0.4))
+ #:cargo-development-inputs
+ (("rust-cipher" ,rust-cipher-0.4))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "Blowfish block cipher")
+ (description "Blowfish block cipher")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-botan-0.10
(package
(name "rust-botan")