summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-07 22:16:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 23:52:35 +0100
commit6e8b38d3e88545d7b3d3f6318e536d8269358664 (patch)
tree095ca2ad9978f13023f76c0747e9522070d29808 /gnu/packages/cran.scm
parentf0bff69873b53a9bdcf3817bc02162354c5256b4 (diff)
downloadguix-patches-6e8b38d3e88545d7b3d3f6318e536d8269358664.tar
guix-patches-6e8b38d3e88545d7b3d3f6318e536d8269358664.tar.gz
gnu: Add r-furrr.
* gnu/packages/cran.scm (r-furrr): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cf00ee5e23..5d401e38fd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6814,6 +6814,32 @@ not found in either TASSEL or @code{r-qtl} in addition to visualization of
genotypes as \"graphical genotypes\".")
(license license:gpl3)))
+(define-public r-furrr
+ (package
+ (name "r-furrr")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "furrr" version))
+ (sha256
+ (base32
+ "1ld9aa9hydna94hgm6p91zjbfv1dz1vsgchjlpknkg6irbvkfafx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-future" ,r-future)
+ ("r-globals" ,r-globals)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/DavisVaughan/furrr")
+ (synopsis "Apply mapping functions in parallel using futures")
+ (description
+ "This package provides implementations of the family of @code{map()}
+functions from the @code{purrr} package that can be resolved using any
+@code{future}-supported backend, e.g. parallel on the local machine or
+distributed on a compute cluster.")
+ (license license:lgpl2.1+)))
+
(define-public r-abjutils
(package
(name "r-abjutils")