summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-02 15:52:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-03 17:53:42 +0200
commita8cba9dd112528d67a946eee057c838221eb5249 (patch)
treeef1403e24d1b98ddd4e67c844d7c6f1720d3969c /gnu/packages/cran.scm
parent736332c79c17fa76282ae8468927eea0ccc90541 (diff)
downloadguix-patches-a8cba9dd112528d67a946eee057c838221eb5249.tar
guix-patches-a8cba9dd112528d67a946eee057c838221eb5249.tar.gz
gnu: r-rcpp: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-rcpp): Move from here... * gnu/packages/cran.scm (r-rcpp): ...to here.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 083eed1dbf..863c872d14 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -82,3 +82,27 @@ Docstrings (PEP-0257) and Julia's Triple-Quoted String Literals.")
the plog header-only C++ logging library, and a method to log to R's standard
error stream.")
(license license:expat)))
+
+(define-public r-rcpp
+ (package
+ (name "r-rcpp")
+ (version "0.12.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rcpp" version))
+ (sha256
+ (base32 "1byyqvlgb2p46p1gv243k73rk69fa8pa4l5m5asmckag2pkb2glz"))))
+ (build-system r-build-system)
+ (home-page "http://www.rcpp.org")
+ (synopsis "Seamless R and C++ integration")
+ (description
+ "The Rcpp package provides R functions as well as C++ classes which offer
+a seamless integration of R and C++. Many R data types and objects can be
+mapped back and forth to C++ equivalents which facilitates both writing of new
+code as well as easier integration of third-party libraries. Documentation
+about Rcpp is provided by several vignettes included in this package, via the
+'Rcpp Gallery' site at <http://gallery.rcpp.org>, the paper by Eddelbuettel
+and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
+'citation(\"Rcpp\")' for details on these last two.")
+ (license license:gpl2+)))