summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-30 20:28:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-30 20:30:02 +0100
commit53a16a2143bbc3cc5f9f014ab6fb6afc9d0064d6 (patch)
treeeca76bde69438ea6f350341194f5b7d2f4e237a2 /gnu/packages/cran.scm
parent79bc8123574f8877c82577af85138e6bf70995c5 (diff)
downloadguix-patches-53a16a2143bbc3cc5f9f014ab6fb6afc9d0064d6.tar
guix-patches-53a16a2143bbc3cc5f9f014ab6fb6afc9d0064d6.tar.gz
gnu: Add r-seuratdata.
* gnu/packages/cran.scm (r-seuratdata): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 504da4e3da..5f12cc55bf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -28740,6 +28740,44 @@ rapid and on-disk conversion between h5Seurat and AnnData objects, with the
goal of enhancing interoperability between Seurat and Scanpy.")
(license license:gpl3))))
+(define-public r-seuratdata
+ (let ((commit "b59556b24d7d6728a5744c9c715dd5f7f32ed7a5")
+ (revision "1"))
+ (package
+ (name "r-seuratdata")
+ (version (git-version "0.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/satijalab/seurat-data")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xfdmdmgn4r0z6w4cxa98ic6xk8i6qz054r215dvqbjs1vydsbf9"))))
+ (properties `((upstream-name . "SeuratData")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; When there is no HOME directory, this package will fail to load
+ ;; the included list of packages.
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ `(("r-cli" ,r-cli)
+ ("r-crayon" ,r-crayon)
+ ("r-rappdirs" ,r-rappdirs)))
+ (home-page "https://github.com/satijalab/seurat-data")
+ (synopsis "Install and manage Seurat datasets")
+ (description
+ "Single cell RNA sequencing datasets can be large, consisting of
+matrices that contain expression data for several thousand features across
+several thousand cells. This package is designed to easily install, manage,
+and learn about various single-cell datasets, provided Seurat objects and
+distributed as independent packages.")
+ (license license:gpl3))))
+
(define-public r-phangorn
(package
(name "r-phangorn")