summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:10:46 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:08 +0100
commitcb360afd66b8534b957a8fc9cbf87ce0f35f7e0c (patch)
tree70f8ad01e9a94cb0f76dbd00cbbc3b30c763c7fe /gnu/packages/cran.scm
parenta64e355ea680bff5f6047011d936e3a3576d62c9 (diff)
downloadguix-patches-cb360afd66b8534b957a8fc9cbf87ce0f35f7e0c.tar
guix-patches-cb360afd66b8534b957a8fc9cbf87ce0f35f7e0c.tar.gz
gnu: Add r-streamr
* gnu/packages/cran.scm (r-streamr): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 75c11c7af3..6bc6f77a8e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27615,3 +27615,29 @@ to read in plain ndjson files or compressed (@code{gz}) ndjson files and either
validate the format of the records or create \"flat\" @code{data.table}
structures from them.")
(license license:expat)))
+
+(define-public r-streamr
+ (package
+ (name "r-streamr")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "streamR" version))
+ (sha256
+ (base32
+ "1clx3b0j2515r1nmnl6ki7qw5n54q3x2jvqv3zrc00kq71mlj7ix"))))
+ (properties `((upstream-name . "streamR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ndjson" ,r-ndjson)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rjson" ,r-rjson)))
+ (home-page
+ "https://cran.r-project.org/package=streamR")
+ (synopsis
+ "Access to Twitter Streaming API via R")
+ (description
+ "This package provides functions to access Twitter's filter, sample, and
+user streams, and to parse the output into data frames.")
+ (license license:gpl2)))