summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 13:27:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 13:27:15 +0200
commit84392227e3e6646d2c01f08dcb774f30cbda10a1 (patch)
tree9a95b5c5000b2ea74f1e31c3468f1f37b206cdfc /gnu/packages/cran.scm
parent4506ef4286f2892ffec9e721efdb79ef3af35d0f (diff)
downloadguix-patches-84392227e3e6646d2c01f08dcb774f30cbda10a1.tar
guix-patches-84392227e3e6646d2c01f08dcb774f30cbda10a1.tar.gz
gnu: Add r-superlearner.
* gnu/packages/cran.scm (r-superlearner): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 16310b6566..23760bceb5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9735,6 +9735,32 @@ S\" (Chambers and Hastie (eds), 1991), and \"Generalized Additive
Models\" (Hastie and Tibshirani, 1990).")
(license license:gpl2)))
+(define-public r-superlearner
+ (package
+ (name "r-superlearner")
+ (version "2.0-28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SuperLearner" version))
+ (sha256
+ (base32
+ "00any24msgflyagy87nznpfjz5g9v15frqda6c679wa8plx26hjz"))))
+ (properties `((upstream-name . "SuperLearner")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cvauc" ,r-cvauc)
+ ("r-gam" ,r-gam)
+ ("r-nnls" ,r-nnls)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ecpolley/SuperLearner")
+ (synopsis "Super learner prediction")
+ (description
+ "This package implements the super learner prediction method and contains
+a library of prediction algorithms to be used in the super learner.")
+ (license license:gpl3)))
+
(define-public r-mosaiccore
(package
(name "r-mosaiccore")