summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 14:11:39 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 14:11:39 +0200
commite7698cb20a58ec1fc8382ea6ff25f3f9ddaee2b0 (patch)
tree6f274ec402cb210be7a4f4e9b94fc27ddfd8c356 /gnu/packages/cran.scm
parent89fd577ec2c0a431d0522617227ee99447b3db6c (diff)
downloadguix-patches-e7698cb20a58ec1fc8382ea6ff25f3f9ddaee2b0.tar
guix-patches-e7698cb20a58ec1fc8382ea6ff25f3f9ddaee2b0.tar.gz
gnu: Add r-pacman.
* gnu/packages/cran.scm (r-pacman): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 56e74da32d..a1c7d4c29b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -719,6 +719,28 @@ provides methods for automatically determining breaks and labels for axes and
legends.")
(license license:expat)))
+(define-public r-pacman
+ (package
+ (name "r-pacman")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pacman" version))
+ (sha256
+ (base32
+ "0z7gngd6h83cpjhq1vg75wvzhdjbgjh7gj5d4zvvi9gd2lmagjcy"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-remotes" ,r-remotes)))
+ (home-page "https://github.com/trinker/pacman")
+ (synopsis "Package Management Tool")
+ (description "This package provides tools to more conveniently perform
+tasks associated with add-on packages. @code{pacman} conveniently wraps
+library and package related functions and names them in an intuitive and
+consistent fashion. It seeks to combine functionality from lower level
+functions which can speed up workflow.")
+ (license license:gpl2)))
+
(define-public r-pheatmap
(package
(name "r-pheatmap")