summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:41:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commitaec7d6be709d7237824af8eb0855e0bb5e89c3cc (patch)
tree5c3f99c1f760b9fe68ef11b0c1c2278a973dbb13 /gnu/packages/cran.scm
parent87ba9508e9362852d76119044c2c53abae7ccf87 (diff)
downloadguix-patches-aec7d6be709d7237824af8eb0855e0bb5e89c3cc.tar
guix-patches-aec7d6be709d7237824af8eb0855e0bb5e89c3cc.tar.gz
gnu: r-getopt: Move from bioinformatics to cran.
* gnu/packages/bioinformatics.scm (r-getopt): Move from here... * gnu/packages/cran.scm (r-getopt): ...to here.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f00d84fe2b..3ef45a21c9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4578,3 +4578,25 @@ more detailed one displaying different types of relevant information for the
molecules in a given set of categories (circle plot, chord plot, cluster plot,
Venn diagram, heatmap).")
(license license:gpl2)))
+
+(define-public r-getopt
+ (package
+ (name "r-getopt")
+ (version "1.20.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "getopt" version))
+ (sha256
+ (base32
+ "13p35lbpy7i578752fa71sbfvcsqw5qfa9p6kf8b5m3c5p9i4v1x"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/trevorld/getopt")
+ (synopsis "Command-line option processor for R")
+ (description
+ "This package is designed to be used with Rscript to write shebang
+scripts that accept short and long options. Many users will prefer to
+use the packages @code{optparse} or @code{argparse} which add extra
+features like automatically generated help options and usage texts,
+support for default values, positional argument support, etc.")
+ (license license:gpl2+)))