summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:41:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commit87ba9508e9362852d76119044c2c53abae7ccf87 (patch)
treec1917082c39ef31b117b79cfed8f75ee7d5b05b3 /gnu/packages/cran.scm
parent64abd24517acbc43daf13bbdb1f73f547649c90b (diff)
downloadguix-patches-87ba9508e9362852d76119044c2c53abae7ccf87.tar
guix-patches-87ba9508e9362852d76119044c2c53abae7ccf87.tar.gz
gnu: Add r-goplot.
* gnu/packages/cran.scm (r-goplot): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 77f27c35bd..f00d84fe2b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4546,3 +4546,35 @@ including Wallenius' noncentral hypergeometric distribution and Fisher's
noncentral hypergeometric distribution (also called extended hypergeometric
distribution).")
(license license:gpl3)))
+
+(define-public r-goplot
+ (package
+ (name "r-goplot")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GOplot" version))
+ (sha256
+ (base32
+ "1y8dv0kbzpr9za91njw0x233vx5d13vqml9hmpddcyi9s6va5nix"))))
+ (properties `((upstream-name . "GOplot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggdendro" ,r-ggdendro)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "https://github.com/wencke/wencke.github.io")
+ (synopsis "Visualization of functional analysis data")
+ (description
+ "This package provides an implementation of multilayered visualizations
+for enhanced graphical representation of functional analysis data. It
+combines and integrates omics data derived from expression and functional
+annotation enrichment analyses. Its plotting functions have been developed
+with an hierarchical structure in mind: starting from a general overview to
+identify the most enriched categories (modified bar plot, bubble plot) to a
+more detailed one displaying different types of relevant information for the
+molecules in a given set of categories (circle plot, chord plot, cluster plot,
+Venn diagram, heatmap).")
+ (license license:gpl2)))