summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-04 15:34:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-04 15:55:00 +0200
commit3a104c5f9d5e5b22dde9fcd31e3fa39537984667 (patch)
treed1a585b8e37aafe2e47acb13399a087d62cef17e /gnu/packages/cran.scm
parente9357f126fa030b89c475f304ce91d259fb18a27 (diff)
downloadguix-patches-3a104c5f9d5e5b22dde9fcd31e3fa39537984667.tar
guix-patches-3a104c5f9d5e5b22dde9fcd31e3fa39537984667.tar.gz
gnu: Add r-tensorflow.
* gnu/packages/cran.scm (r-tensorflow): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0320fe681f..ad1427d388 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30122,3 +30122,34 @@ This package provides a unique, time stamped directory for each run along with
functions to retrieve the directory of the latest run or latest several
runs.")
(license license:asl2.0)))
+
+(define-public r-tensorflow
+ (package
+ (name "r-tensorflow")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tensorflow" version))
+ (sha256
+ (base32
+ "00g9w4xmdyjl4578kmhng58k7afjkj2vwgcq2ik8rqwljkcz5pph"))))
+ (properties `((upstream-name . "tensorflow")))
+ (build-system r-build-system)
+ (inputs `(("tensorflow" ,tensorflow)))
+ (propagated-inputs
+ `(("r-config" ,r-config)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-processx" ,r-processx)
+ ("r-reticulate" ,r-reticulate)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-tfruns" ,r-tfruns)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/rstudio/tensorflow")
+ (synopsis "R interface to TensorFlow")
+ (description
+ "R interface to TensorFlow a library for numerical computation using data
+flow graphs. Nodes in the graph represent mathematical operations, while the
+graph edges represent the multidimensional data arrays (tensors) communicated
+between them.")
+ (license license:asl2.0)))