summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-12 12:41:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-13 01:19:38 +0200
commita620d22ea827a64ecfaead165e5b78be9861f324 (patch)
tree63f654fdbae1a0a58fc199bbb5649065f9b6b7f6 /gnu/packages/cran.scm
parentdb6290af7cea3434a72d98c007cb6f5d0d72b1b1 (diff)
downloadguix-patches-a620d22ea827a64ecfaead165e5b78be9861f324.tar
guix-patches-a620d22ea827a64ecfaead165e5b78be9861f324.tar.gz
gnu: r-gprofiler: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-gprofiler): Move this variable from here... * gnu/packages/cran.scm (r-gprofiler): ...to here.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7fa47aee1c..7c37f8eb59 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -158,6 +158,30 @@ the system clipboards.")
respecting the grammar of its graphics paradigm.")
(license license:gpl2+)))
+(define-public r-gprofiler
+ (package
+ (name "r-gprofiler")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gProfileR" version))
+ (sha256
+ (base32
+ "1h1v0kgpsn04ald2izznh7fr2riwisj5hcgz4k7h3qc931rf0r4k"))))
+ (properties `((upstream-name . "gProfileR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-plyr" ,r-plyr)
+ ("r-rcurl" ,r-rcurl)))
+ (home-page "https://cran.r-project.org/web/packages/gProfileR/")
+ (synopsis "Interface to the g:Profiler toolkit")
+ (description
+ "This package provides tools for functional enrichment analysis,
+gene identifier conversion and mapping homologous genes across related
+organisms via the @code{g:Profiler} toolkit.")
+ (license license:gpl2+)))
+
(define-public r-oenb
(package
(name "r-oenb")