summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:53:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commitd28be7b76b58fd86cfc6fa5f0fa6ad95b1e633c6 (patch)
tree128e487afaaa0968114cb2948cdb2dacbf58a118 /gnu/packages/cran.scm
parent9401f56b814d9ff68b280d0df853823e56865ab7 (diff)
downloadguix-patches-d28be7b76b58fd86cfc6fa5f0fa6ad95b1e633c6.tar
guix-patches-d28be7b76b58fd86cfc6fa5f0fa6ad95b1e633c6.tar.gz
gnu: Add r-als.
* gnu/packages/cran.scm (r-als): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 32f25956c5..44f79a5f3e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9283,3 +9283,34 @@ linear order on both variables.")
\"Chemometrics with R - Multivariate Data Analysis in the Natural Sciences and
Life Sciences\" by Ron Wehrens, Springer (2011).")
(license license:gpl2+)))
+
+(define-public r-als
+ (package
+ (name "r-als")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ALS" version))
+ (sha256
+ (base32
+ "1swrn39vy50fazkpf97r7c542gkj6mlvy8gmcxllg7mf2mqx546a"))))
+ (properties `((upstream-name . "ALS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-iso" ,r-iso)
+ ("r-nnls" ,r-nnls)))
+ (home-page "https://cran.r-project.org/web/packages/ALS")
+ (synopsis "Multivariate curve resolution alternating least squares")
+ (description
+ "Alternating least squares is often used to resolve components
+contributing to data with a bilinear structure; the basic technique may be
+extended to alternating constrained least squares. This package provides an
+implementation of @dfn{multivariate curve resolution alternating least
+squares} (MCR-ALS).
+
+Commonly applied constraints include unimodality, non-negativity, and
+normalization of components. Several data matrices may be decomposed
+simultaneously by assuming that one of the two matrices in the bilinear
+decomposition is shared between datasets.")
+ (license license:gpl2+)))