summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-03 10:32:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-03 10:34:23 +0100
commit81e0b62502e928f2a1b3e9370241a1d881ac7766 (patch)
treee2787fb28563513e0ddbcf4cd328744be8d10b86 /gnu/packages/cran.scm
parent0f3142e7c31761cfdbb9d5c803c70c6263c98791 (diff)
downloadguix-patches-81e0b62502e928f2a1b3e9370241a1d881ac7766.tar
guix-patches-81e0b62502e928f2a1b3e9370241a1d881ac7766.tar.gz
gnu: Add r-ggrepel.
* gnu/packages/cran.scm (r-ggrepel): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9a27c82d21..03356cb6fd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1243,3 +1243,27 @@ X, and likewise for Y. Pdist strictly computes distances across the two
matrices, not within the same matrix, making computations significantly faster
for certain use cases.")
(license license:gpl3+)))
+
+(define-public r-ggrepel
+ (package
+ (name "r-ggrepel")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggrepel" version))
+ (sha256
+ (base32
+ "0g0qfm6g71rv27423c1x846ipilnj213knyzrcr09vrpxc87l618"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-rcpp" ,r-rcpp)
+ ("r-scales" ,r-scales)))
+ (home-page "http://github.com/slowkow/ggrepel")
+ (synopsis "Repulsive text and label geometries for ggplot2")
+ (description
+ "This package provides text and label geometries for ggplot2 that help to
+avoid overlapping text labels. Labels repel away from each other and away
+from the data points.")
+ (license license:gpl3)))