summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-15 15:52:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:12 +0200
commit6b4a9aec239e347de0e1cc323b1be1980102efd2 (patch)
tree5e64b8334062065dd20df0d13f7b9d2cf4e9b724 /gnu/packages/cran.scm
parent521e0703d8bc925c8b4845339a9a2e17307c87ca (diff)
downloadguix-patches-6b4a9aec239e347de0e1cc323b1be1980102efd2.tar
guix-patches-6b4a9aec239e347de0e1cc323b1be1980102efd2.tar.gz
gnu: Add r-fitdistrplus.
* gnu/packages/cran.scm (r-fitdistrplus): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 746c778b2c..134139017f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -819,3 +819,31 @@ It includes banded and tridiagonal linear systems. The package calls Fortran
functions from LINPACK.")
;; Any GPL version.
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-fitdistrplus
+ (package
+ (name "r-fitdistrplus")
+ (version "1.0-9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fitdistrplus" version))
+ (sha256
+ (base32
+ "18x9454g598d54763k3hvi33iszifk7sxvhd1zg5r8z1vpixx3z6"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-survival" ,r-survival)))
+ (home-page "http://riskassessment.r-forge.r-project.org")
+ (synopsis "Fitting a parametric distribution from data")
+ (description
+ "This package extends the @code{fitdistr} function of the MASS package
+with several functions to help the fit of a parametric distribution to
+non-censored or censored data. Censored data may contain left-censored,
+right-censored and interval-censored values, with several lower and upper
+bounds. In addition to @dfn{maximum likelihood estimation} (MLE), the package
+provides moment matching (MME), quantile matching (QME) and maximum
+goodness-of-fit estimation (MGE) methods (available only for non-censored
+data). Weighted versions of MLE, MME and QME are available.")
+ (license license:gpl2+)))