summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:48:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commit00436e2cacec4a70e6e86a7663af754e2921c1e9 (patch)
treefbfb5e033939ed67a88b743cc31f56c85386bf8c /gnu/packages/cran.scm
parent2871b670a8075e876873296dfa7ac11628926fc9 (diff)
downloadguix-patches-00436e2cacec4a70e6e86a7663af754e2921c1e9.tar
guix-patches-00436e2cacec4a70e6e86a7663af754e2921c1e9.tar.gz
gnu: Add r-nnls.
* gnu/packages/cran.scm (r-nnls): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f768bcc5ba..af8a4dae1d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9213,3 +9213,24 @@ maps} (SOMs). Also interrogation of the maps and prediction using trained
maps are supported. The name of the package refers to Teuvo Kohonen, the
inventor of the SOM.")
(license license:gpl2+)))
+
+(define-public r-nnls
+ (package
+ (name "r-nnls")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nnls" version))
+ (sha256
+ (base32
+ "07vcrrxvswrvfiha6f3ikn640yg0m2b4yd9lkmim1g0jmsmpfp8f"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/nnls")
+ (synopsis "Lawson-Hanson algorithm for non-negative least squares")
+ (description
+ "This package provides an R interface to the Lawson-Hanson implementation
+of an algorithm for @dfn{non-negative least squares} (NNLS). It also allows
+the combination of non-negative and non-positive constraints.")
+ (license license:gpl2+)))