summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:38:48 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:15 +0100
commit3095255b7bdb194479dbc58d6d51dff752b3352f (patch)
tree6cb7dd441bc46c7abb7d35393982e8c787fbc829 /gnu/packages/cran.scm
parent82344f59363530a092f4bbaca809820b2077b5fe (diff)
downloadguix-patches-3095255b7bdb194479dbc58d6d51dff752b3352f.tar
guix-patches-3095255b7bdb194479dbc58d6d51dff752b3352f.tar.gz
gnu: Add r-tmaptools.
* gnu/packages/cran.scm (r-tmaptools): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3581d51ee0..a539042a24 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27909,3 +27909,35 @@ light-weight geometry library used by @url{http://postgis.net/,PostGIS}.")
(raster and vector data cubes) in @code{R}, using @code{GDAL} bindings provided
by @code{sf}, and @code{NetCDF} bindings by @code{ncmeta} and @code{RNetCDF}.")
(license license:asl2.0)))
+
+(define-public r-tmaptools
+ (package
+ (name "r-tmaptools")
+ (version "3.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tmaptools" version))
+ (sha256
+ (base32
+ "0bal3czrdr93qig8s5cf5szld5vjbbks67rismfhlkmlgw6wp2gx"))))
+ (properties `((upstream-name . "tmaptools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dichromat" ,r-dichromat)
+ ("r-lwgeom" ,r-lwgeom)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-sf" ,r-sf)
+ ("r-stars" ,r-stars)
+ ("r-units" ,r-units)
+ ("r-viridislite" ,r-viridislite)
+ ("r-xml" ,r-xml)))
+ (home-page
+ "https://github.com/mtennekes/tmaptools")
+ (synopsis "Thematic Map Tools")
+ (description
+ "Set of tools for reading and processing spatial data. The aim is to
+supply the workflow to create thematic maps. This package also facilitates
+@code{tmap}, the package for visualizing thematic maps.")
+ (license license:gpl3)))