summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:08:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:56 +0100
commitf3233beec5c403e95e0ab102fd4d109dffd59219 (patch)
tree9c3b7545a43604c3369b6a65503322865f35a604 /gnu/packages/cran.scm
parentc691c607d7682d08b079e4e168b9392de234b3fb (diff)
downloadguix-patches-f3233beec5c403e95e0ab102fd4d109dffd59219.tar
guix-patches-f3233beec5c403e95e0ab102fd4d109dffd59219.tar.gz
gnu: Add r-blockmodeling.
* gnu/packages/cran.scm (r-blockmodeling): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 67a1950756..ac0d497e90 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10868,3 +10868,30 @@ convert standard @code{%dopar%} loops into fully reproducible loops,
independently of the number of workers, the task scheduling strategy, or the
chosen parallel environment and associated foreach backend.")
(license license:gpl2+)))
+
+(define-public r-blockmodeling
+ (package
+ (name "r-blockmodeling")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "blockmodeling" version))
+ (sha256
+ (base32
+ "11v9903y9dwlzaqp8sx0fsibcg82phvappddy37r8lnxd4vchsd2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-doparallel" ,r-doparallel)
+ ("r-dorng" ,r-dorng)
+ ("r-foreach" ,r-foreach)
+ ("r-matrix" ,r-matrix)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/blockmodeling")
+ (synopsis "Generalized and classical blockmodeling of valued networks")
+ (description
+ "This package is primarily meant as an implementation of generalized
+blockmodeling for valued networks. In addition, measures of similarity or
+dissimilarity based on structural equivalence and regular equivalence (REGE
+algorithms) can be computed and partitioned matrices can be plotted.")
+ (license license:gpl2+)))