summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:56 +0100
commit262ab4b17cd75e51b60ee34e6303722b654d3e09 (patch)
tree66a1389a00aa8f421df880c128d876f882e84d8c /gnu/packages/cran.scm
parent8cd3f49d464935d2b266de112aa4b69e7609fae0 (diff)
downloadguix-patches-262ab4b17cd75e51b60ee34e6303722b654d3e09.tar
guix-patches-262ab4b17cd75e51b60ee34e6303722b654d3e09.tar.gz
gnu: Add r-tensora.
* gnu/packages/cran.scm (r-tensora): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 877ddea19b..32505a1208 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10976,3 +10976,26 @@ instrumental variables models, Analysis of Multivariate Ordinal survey data
with scale usage heterogeneity, and Bayesian Analysis of Aggregate Random
Coefficient Logit Models.")
(license license:gpl2+)))
+
+(define-public r-tensora
+ (package
+ (name "r-tensora")
+ (version "0.36.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tensorA" version))
+ (sha256
+ (base32
+ "176hjy3bvg3in62r97wxbhq187sjz6c1gwy9x6spaxl6k4my3zy7"))))
+ (properties `((upstream-name . "tensorA")))
+ (build-system r-build-system)
+ (home-page "http://www.stat.boogaart.de/tensorA")
+ (synopsis "Advanced tensor arithmetic with named indices")
+ (description
+ "This package provides convenience functions for advanced linear algebra
+with tensors and computation with datasets of tensors on a higher level
+abstraction. It includes Einstein and Riemann summing conventions, dragging,
+co- and contravariate indices, and parallel computations on sequences of
+tensors.")
+ (license license:gpl2+)))