summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:55:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:09 +0200
commitac8402072b550c6a661f4aca7171bd070e0bc6b9 (patch)
treef86102b128a84ed8b7c026e2acbfddb72a8665fb /gnu/packages/cran.scm
parentc9c6f4b543a0aaf2da6512768cf54c898fd784df (diff)
downloadguix-patches-ac8402072b550c6a661f4aca7171bd070e0bc6b9.tar
guix-patches-ac8402072b550c6a661f4aca7171bd070e0bc6b9.tar.gz
gnu: Add r-ggally.
* gnu/packages/cran.scm (r-ggally): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d88202ca5a..35d0965143 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -499,3 +499,34 @@ percentage, elapsed time, and/or the estimated completion time. They work in
terminals, in Emacs ESS, RStudio, Windows Rgui, and the macOS R.app. The
package also provides a C++ API, that works with or without Rcpp.")
(license license:expat)))
+
+(define-public r-ggally
+ (package
+ (name "r-ggally")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GGally" version))
+ (sha256
+ (base32
+ "12ddab0nd0f9c7bb6cx3c22mliyvc8xsxv26aqz3cvfbla8crp3b"))))
+ (properties `((upstream-name . "GGally")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-plyr" ,r-plyr)
+ ("r-progress" ,r-progress)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-reshape" ,r-reshape)))
+ (home-page "https://ggobi.github.io/ggally")
+ (synopsis "Extension to ggplot2")
+ (description
+ "The R package ggplot2 is a plotting system based on the grammar of
+graphics. GGally extends ggplot2 by adding several functions to reduce the
+complexity of combining geometric objects with transformed data. Some of
+these functions include a pairwise plot matrix, a two group pairwise plot
+matrix, a parallel coordinates plot, a survival plot, and several functions to
+plot networks.")
+ (license license:gpl2+)))