summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-11 02:55:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-18 11:33:25 +0200
commit5a87093fd57f136cb9091d2d97d3674e8dac6e61 (patch)
treec50ebbb36dbcc6c9e515a34072a1b8dfe5f86d06 /gnu/packages/cran.scm
parentf57b883ea3beed434244b401573452f8f3a63c1f (diff)
downloadguix-patches-5a87093fd57f136cb9091d2d97d3674e8dac6e61.tar
guix-patches-5a87093fd57f136cb9091d2d97d3674e8dac6e61.tar.gz
gnu: Add r-gower.
* gnu/packages/cran.scm (r-gower): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5a81416767..1256eb30bd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1104,3 +1104,25 @@ classification is done. It also offers an extension to functional data and
routines for calculating certain notions of statistical depth functions. 50
multivariate and 5 functional classification problems are included.")
(license license:gpl2)))
+
+(define-public r-gower
+ (package
+ (name "r-gower")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gower" version))
+ (sha256
+ (base32
+ "1mbrj1lam3jfbby2j32shmmj5cn09zx3rkxbamq7q8sdg39b54gb"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/markvanderloo/gower")
+ (synopsis "Gower's distance")
+ (description
+ "This package provides tools to compute Gower's distance (or similarity)
+coefficient between records, and to compute the top-n matches between records.
+Core algorithms are executed in parallel on systems supporting OpenMP.")
+ (license license:gpl3)))