summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 17:57:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:25:47 +0200
commit4847a62ea9414dad19d4d44ee70099fbb8a691ca (patch)
tree65e4565dd629150387c135b026c9695962c744e1 /gnu/packages/cran.scm
parent2bdb5c3f78c2cf63ba36922823c6d67657fa3056 (diff)
downloadguix-patches-4847a62ea9414dad19d4d44ee70099fbb8a691ca.tar
guix-patches-4847a62ea9414dad19d4d44ee70099fbb8a691ca.tar.gz
gnu: Add r-globaloptions.
* gnu/packages/cran.scm (r-globaloptions): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index de7c56f6df..7179ceb5c6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -213,3 +213,23 @@ on (non-orthogonal) variable vectors in scatterplots and biplots.")
"This package provides functions for plotting graphical shapes such as
ellipses, circles, cylinders, arrows, ...")
(license license:gpl3+)))
+
+(define-public r-globaloptions
+ (package
+ (name "r-globaloptions")
+ (version "0.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GlobalOptions" version))
+ (sha256
+ (base32
+ "1abpc03cfvazbwj2sx6qgngs5pgpzysvxkana20hyvb4n7ws77f0"))))
+ (properties `((upstream-name . "GlobalOptions")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jokergoo/GlobalOptions")
+ (synopsis "Generate functions to get or set global options")
+ (description
+ "This package provides more controls on the option values such as
+validation and filtering on the values, making options invisible or private.")
+ (license license:gpl2+)))