summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-19 00:01:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-20 12:00:34 +0200
commitc87a33586040f81554c30c973679f3b1f2a86659 (patch)
treebeadb0377ce5ad1f6eec234d818d39c42ffdedb7 /gnu/packages/cran.scm
parent154c2b0bc5d812f3dbb76110c25742044c7d22ec (diff)
downloadguix-patches-c87a33586040f81554c30c973679f3b1f2a86659.tar
guix-patches-c87a33586040f81554c30c973679f3b1f2a86659.tar.gz
gnu: Add r-zeallot.
* gnu/packages/cran.scm (r-zeallot): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a5bfcf6a36..a876746ae6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3653,6 +3653,27 @@ international text (Unicode). Input, validate, normalize, encode, format, and
display.")
(license license:asl2.0)))
+(define-public r-zeallot
+ (package
+ (name "r-zeallot")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "zeallot" version))
+ (sha256
+ (base32
+ "1sd1igcfnv27pa3bqxlbyxchi562h7grnjg1l7wxx3bwr49i57s3"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/nteetor/zeallot")
+ (synopsis "Multiple, unpacking, and destructuring assignment")
+ (description
+ "This package provides a @code{%<-%} operator to perform multiple,
+unpacking, and destructuring assignment in R. The operator unpacks the
+right-hand side of an assignment into multiple values and assigns these values
+to variables on the left-hand side of the assignment.")
+ (license license:expat)))
+
(define-public r-pillar
(package
(name "r-pillar")