summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-12-29 19:00:39 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-12-29 19:00:39 +0100
commit0c8bb20b7cbd39537999fce29979a6acaf64e601 (patch)
tree69761e385ec4635f62db1affe5fc7be06c5ea41f /gnu/packages/cran.scm
parent610cd6a170474550dffd8a58eb3651ef10ca7f6e (diff)
downloadguix-patches-0c8bb20b7cbd39537999fce29979a6acaf64e601.tar
guix-patches-0c8bb20b7cbd39537999fce29979a6acaf64e601.tar.gz
gnu: r-ldheatmap: Fix missing variable.
This is a follow-up of 61ec8928c7fee048fea37558508eb0a80022684b. * gnu/packages/cran.scm (r-ldheatmap)[propagated-inputs]: Use 'module-ref' to resolve r-snpstats variable which is located in (gnu package bioinformatics) that cannot be included due to a circular dependency.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 10212e2a68..c0926d9fb3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14734,7 +14734,9 @@ inbred lines, F2 intercrosses, and association mapping populations.")
(propagated-inputs
`(("r-genetics" ,r-genetics)
("r-rcpp" ,r-rcpp)
- ("r-snpstats" ,r-snpstats)))
+ ("r-snpstats" ,(module-ref
+ (resolve-interface '(gnu packages bioconductor))
+ 'r-snpstats))))
(home-page "https://stat.sfu.ca/statgen/research/ldheatmap.html")
(synopsis "Graphical display of pairwise linkage disequilibria between SNPs")
(description