summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-14 14:45:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-14 14:51:00 +0200
commitba4e73322eaa09333573c1d45182a54d914477d4 (patch)
tree9c1a72260d9251d123e977b933b195e62227a962 /gnu/packages/cran.scm
parent35b1ba704aa6f69462e0d34e3e45c034706c35ff (diff)
downloadguix-patches-ba4e73322eaa09333573c1d45182a54d914477d4.tar
guix-patches-ba4e73322eaa09333573c1d45182a54d914477d4.tar.gz
gnu: Add r-spectrum.
* gnu/packages/cran.scm (r-spectrum): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ba15f40680..f382d1f9b2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23026,3 +23026,36 @@ see
@end enumerate
")
(license license:gpl3)))
+
+(define-public r-spectrum
+ (package
+ (name "r-spectrum")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Spectrum" version))
+ (sha256
+ (base32
+ "0n38d360azkck6vvhr771zsh0gbvd9qsf9ygg5r18vhz0pb1xcfw"))))
+ (properties `((upstream-name . "Spectrum")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-clusterr" ,r-clusterr)
+ ("r-diptest" ,r-diptest)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-rfast" ,r-rfast)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/Spectrum/")
+ (synopsis "Fast adaptive spectral clustering for single and multi-view data")
+ (description
+ "This package provides a self-tuning spectral clustering method for
+single or multi-view data. Spectrum uses a new type of adaptive density aware
+kernel that strengthens connections in the graph based on common nearest
+neighbours. It uses a tensor product graph data integration and diffusion
+procedure to integrate different data sources and reduce noise. Spectrum uses
+either the eigengap or multimodality gap heuristics to determine the number of
+clusters. The method is sufficiently flexible so that a wide range of
+Gaussian and non-Gaussian structures can be clustered with automatic selection
+of K.")
+ (license license:agpl3+)))