summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-14 14:44:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-14 14:51:00 +0200
commit35b1ba704aa6f69462e0d34e3e45c034706c35ff (patch)
treeb1dc0e9a61de0b3143c56f6412b90fe9b3822987 /gnu/packages/cran.scm
parenta86f51dccaa7292630e4a2d91330f3e7f67ecac5 (diff)
downloadguix-patches-35b1ba704aa6f69462e0d34e3e45c034706c35ff.tar
guix-patches-35b1ba704aa6f69462e0d34e3e45c034706c35ff.tar.gz
gnu: Add r-clusterr.
* gnu/packages/cran.scm (r-clusterr): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 50428f23a5..ba15f40680 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22980,3 +22980,49 @@ analysis. Column- and row- wise means, medians, variances, minimums,
maximums, many t, F and G-square tests, many regressions (normal, logistic,
Poisson), are some of the many fast functions.")
(license license:gpl2+)))
+
+(define-public r-clusterr
+ (package
+ (name "r-clusterr")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ClusterR" version))
+ (sha256
+ (base32
+ "1ky172bk15a78hky77vl60j7c81nq2495sxjrv53is25nkac7sjm"))))
+ (properties `((upstream-name . "ClusterR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gmp" ,r-gmp)
+ ("r-gtools" ,r-gtools)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/mlampros/ClusterR")
+ (synopsis "Clustering")
+ (description
+ "This package provides Gaussian mixture models, k-means,
+mini-batch-kmeans, k-medoids and affinity propagation clustering with the
+option to plot, validate, predict (new data) and estimate the optimal number
+of clusters. The package takes advantage of @code{RcppArmadillo} to speed up
+the computationally intensive parts of the functions. For more information,
+see
+
+@enumerate
+@item \"Clustering in an Object-Oriented Environment\" by Anja Struyf, Mia
+ Hubert, Peter Rousseeuw (1997), Journal of Statistical Software,
+ @url{https://doi.org/10.18637/jss.v001.i04};
+@item \"Web-scale k-means clustering\" by D. Sculley (2010), ACM Digital
+ Library, @url{https://doi.org/10.1145/1772690.1772862};
+@item \"Armadillo: a template-based C++ library
+ for linear algebra\" by Sanderson et al (2016), The Journal of Open Source
+ Software, @url{https://doi.org/10.21105/joss.00026};
+@item \"Clustering by Passing Messages Between Data Points\" by Brendan
+ J. Frey and Delbert Dueck, Science 16 Feb 2007: Vol. 315, Issue 5814,
+ pp. 972-976, @url{https://doi.org/10.1126/science.1136800}.
+@end enumerate
+")
+ (license license:gpl3)))