summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-19 20:13:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-19 20:35:08 +0100
commit2976f304e2f926f6efbb436c3e4ba600d13ac939 (patch)
tree60d42ab4067f0cc3febad4b8ef8297aaa9eec942 /gnu/packages/cran.scm
parentd03949449a1d5ec5042ffaf1e6a42354e1229e3c (diff)
downloadguix-patches-2976f304e2f926f6efbb436c3e4ba600d13ac939.tar
guix-patches-2976f304e2f926f6efbb436c3e4ba600d13ac939.tar.gz
gnu: Add r-cli.
* gnu/packages/cran.scm (r-cli): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3a3fc31bd0..9b80b68984 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1817,3 +1817,25 @@ plots in @code{ggplot2}.")
distributions over time or space. This package enables the creation of such
plots in @code{ggplot2}.")
(license license:gpl2)))
+
+(define-public r-cli
+ (package
+ (name "r-cli")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cli" version))
+ (sha256
+ (base32
+ "07as3dr7vwx02p3qgzlmxz1dlrd3x3lysrzp222ip9jcjpydp8wg"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-crayon" ,r-crayon)))
+ (home-page "https://github.com/r-lib/cli#readme")
+ (synopsis "Helpers for developing command line interfaces")
+ (description "This package provides a suite of tools designed to build
+attractive command line interfaces (CLIs). It includes tools for drawing
+rules, boxes, trees, and Unicode symbols with ASCII alternatives.")
+ (license license:expat)))