summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/cran.scm
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
downloadguix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar
guix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar.gz
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ebfe9fd506..937f53784e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11247,8 +11247,7 @@ correlation, censored, ordered and multivariate problems.")
"0aman4273i8hy3z0qay1nrsr7v27m4icm1j6f4w59ylix80l5myq"))))
(build-system r-build-system)
(inputs
- `(("pandoc" ,pandoc)
- ("pandoc-citeproc" ,pandoc-citeproc)))
+ `(("pandoc" ,pandoc)))
(native-inputs
`(("r-knitr" ,r-knitr)))
(propagated-inputs
@@ -21432,8 +21431,7 @@ the appropriate system call provided by the underlying operating system.")
;; These inputs are needed for vignettes
(native-inputs
`(("r-knitr" ,r-knitr)
- ("r-rmarkdown" ,r-rmarkdown)
- ("pandoc-citeproc" ,pandoc-citeproc)))
+ ("r-rmarkdown" ,r-rmarkdown)))
(home-page "https://github.com/andreyshabalin/filematrix")
(synopsis "File-backed matrix class with convenient read and write access")
(description
@@ -24791,8 +24789,7 @@ recommendations for developers.")
(properties `((upstream-name . "loo")))
(build-system r-build-system)
(inputs
- `(("pandoc" ,pandoc)
- ("pandoc-citeproc" ,pandoc-citeproc)))
+ `(("pandoc" ,pandoc)))
(propagated-inputs
`(("r-checkmate" ,r-checkmate)
("r-matrixstats" ,r-matrixstats)))
@@ -24881,8 +24878,7 @@ need to derive the partial derivatives.")
(properties `((upstream-name . "rstanarm")))
(build-system r-build-system)
(inputs
- `(("pandoc" ,pandoc)
- ("pandoc-citeproc" ,pandoc-citeproc)))
+ `(("pandoc" ,pandoc)))
(propagated-inputs
`(("r-bayesplot" ,r-bayesplot)
("r-bh" ,r-bh)
@@ -28207,8 +28203,7 @@ use.")
(native-inputs
`(("r-knitr" ,r-knitr)
("r-rmarkdown" ,r-rmarkdown)
- ("pandoc" ,pandoc)
- ("pandoc-citeproc" ,pandoc-citeproc))) ; for vignettes
+ ("pandoc" ,pandoc)))
(home-page "https://github.com/tidymodels/tidymodels")
(synopsis "Tidy collection for modeling and statistical analysis")
(description