summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-03-31 12:58:47 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-03-31 16:14:52 +0300
commita83918837e6fb47a4a0c93fea598013b73cd71b8 (patch)
treebd14d76622f7bfd05e02dfb3087b7fb226b3ff73 /gnu/packages/cpp.scm
parent7d331dd20302ca1d7df4fc67bfcedde9d897cc97 (diff)
downloadguix-patches-a83918837e6fb47a4a0c93fea598013b73cd71b8.tar
guix-patches-a83918837e6fb47a4a0c93fea598013b73cd71b8.tar.gz
gnu: atomic-queue: Run tests correctly.
* gnu/packages/cpp.scm (atomic-queue)[arguments]: In the check phase, run tests instead of returning a function to run them. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index bb7f5ab95a..eb48902034 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1297,8 +1297,7 @@ provides a number of utilities to make coding with expected cleaner.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (lambda _
- (invoke "make" "run_tests")))))
+ (invoke "./tests"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(copy-recursively "../source/include/atomic_queue"