summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-02-23 14:11:06 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-02 23:12:36 +0100
commitbe22c87d2df59dffdee7cad8c725a9f3bd3aa9ef (patch)
treeb54796f111426001b6e5ec84b4094dfe56a43e85 /gnu/packages/cpp.scm
parent2075b83b2dbd9896e2e69070e3363f3d43fbe133 (diff)
downloadguix-patches-be22c87d2df59dffdee7cad8c725a9f3bd3aa9ef.tar
guix-patches-be22c87d2df59dffdee7cad8c725a9f3bd3aa9ef.tar.gz
gnu: Add pcg-cpp.
* gnu/packages/cpp.scm (pcg-cpp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 659eb1cdeb..eeb45950af 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -980,3 +980,32 @@ programming environment using the actor model for concurrent, distributed
computation.")
(home-page "https://www.actor-framework.org/")
(license license:bsd-3)))
+
+(define-public pcg-cpp
+ (let ((commit "5b5cac8d61339e810c5dbb4692d868a1d7ca1b2d")
+ (revision "1"))
+ (package
+ (name "pcg-cpp")
+ (version (git-version "0.98.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/imneme/pcg-cpp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s9dcd4iydlc1xj9m6f7c52nlyx99klk043sk7arqy6kp7gdaa33"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (synopsis "C++11 header only library for random number generation")
+ (description "The Permuted Congruential Generator (PCG) extends the
+Linear Congruential Generator (LCG) with a permutation function to increase
+output randomness while retaining speed, simplicity, and conciseness.")
+ (home-page "https://www.pcg-random.org")
+ (license (list license:expat license:asl2.0))))) ; dual licensed