summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-02-01 14:01:11 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-19 22:17:03 +0100
commitc4d616f7c665921e1329c75cd2d0cf05094b1306 (patch)
treec551da5dd7c5597c3eaced730b1a3ac3ce50b63f /gnu/packages/cpp.scm
parentf08a60bbecc46b7918986bb79a34caf537751693 (diff)
downloadguix-patches-c4d616f7c665921e1329c75cd2d0cf05094b1306.tar
guix-patches-c4d616f7c665921e1329c75cd2d0cf05094b1306.tar.gz
gnu: abseil-cpp: Update to 20200923.3.
* gnu/packages/cpp.scm (abseil-cpp): Update to 20200923.3. [arguments]: Enable external googletest. * gnu/packages/patches/abseil-cpp-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 02a82091b8..ba361ba5ca 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -678,7 +678,7 @@ point and then, after each tween step, plugging back the result.")
(define-public abseil-cpp
(package
(name "abseil-cpp")
- (version "20200225.2")
+ (version "20200923.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -687,11 +687,14 @@ point and then, after each tween step, plugging back the result.")
(file-name (git-file-name name version))
(sha256
(base32
- "0dwxg54pv6ihphbia0iw65r64whd7v8nm4wwhcz219642cgpv54y"))))
+ "1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
+ ;; Remove after next googletest release and update.
+ (patches (search-patches "abseil-cpp-fix.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
"-DABSL_RUN_TESTS=ON"
+ "-DABSL_USE_EXTERNAL_GOOGLETEST=ON"
;; Needed, else we get errors like:
;;
;; ld: CMakeFiles/absl_periodic_sampler_test.dir/internal/periodic_sampler_test.cc.o: