summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-11 16:33:51 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-11 16:39:04 +0200
commit73a52906d9b6fec8be812395a8c9c67fac0857f3 (patch)
tree1031d61d939f1fa526d63548322df05c3719dc00 /gnu/packages/cpp.scm
parent2fbae886804839d61781376c598aad19fd21e881 (diff)
downloadguix-patches-73a52906d9b6fec8be812395a8c9c67fac0857f3.tar
guix-patches-73a52906d9b6fec8be812395a8c9c67fac0857f3.tar.gz
gnu: fifo-map: Fix build.
* gnu/packages/cpp.scm (fifo-map)[arguments]: Fix 'install' phase.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 45a02b5735..7ac4b0c39b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -368,10 +369,8 @@ functions, class methods, and stl containers.
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(inc (string-append out "/include/fifo_map")))
- (with-directory-excursion
- (string-append "../" ,name "-" ,version "-checkout")
- (install-file "src/fifo_map.hpp" inc)
- #t)))))))
+ (with-directory-excursion "../source"
+ (install-file "src/fifo_map.hpp" inc))))))))
(synopsis "FIFO-ordered associative container for C++")
(description "Fifo_map is a C++ header only library for associative
container which uses the order in which keys were inserted to the container