summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 00:28:40 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-30 01:00:30 +0100
commitf2059169039561ae3b676e50443c14077d1e03db (patch)
tree4a242f1101cf245b57bbc02503cd42432efc3aa0 /gnu/packages/cpp.scm
parent5d014c696f88563ae95dec22ece8cd45b3a40862 (diff)
downloadguix-patches-f2059169039561ae3b676e50443c14077d1e03db.tar
guix-patches-f2059169039561ae3b676e50443c14077d1e03db.tar.gz
gnu: Add google-highway.
* gnu/packages/cpp.scm (google-highway): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index b6c56cf1a1..fe2ab3772e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -300,6 +300,30 @@ It also provides accelerated implementation of common mathematical functions
operating on batches.")
(license license:bsd-3)))
+(define-public google-highway
+ (package
+ (name "google-highway")
+ (version "0.15.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/highway")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yjwgnrpd9m99x2nqf6ld28zc6y9nlsxqg128bxxmja1gg4g4qdz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DHWY_SYSTEM_GTEST=on")))
+ (native-inputs
+ (list googletest))
+ (home-page "https://github.com/google/highway")
+ (synopsis "SIMD library with runtime dispatch")
+ (description "Highway is a performance-portable, length-agnostic C++
+library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
+ (license license:asl2.0)))
+
(define-public chaiscript
(package
(name "chaiscript")