summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-03-18 17:53:12 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:59 +0200
commitef0c65969b797a22572446df55b40efcff4d4037 (patch)
treee26787a37bc23e6a1dd62becc06f67db33eb3fff /gnu/packages/cpp.scm
parent5ed42eb9a01e63c25d6c0836b6a1b15e8d5fbd74 (diff)
downloadguix-patches-ef0c65969b797a22572446df55b40efcff4d4037.tar
guix-patches-ef0c65969b797a22572446df55b40efcff4d4037.tar.gz
gnu: aws-sdk-cpp: Update to 1.9.92.
* gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch, gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch, gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.92. [source]: Use patches. [inputs, propagated-inputs]: Update AWS dependencies to Common Runtime. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 383c9843ca..15c3f10d72 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -923,7 +923,7 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(define-public aws-sdk-cpp
(package
(name "aws-sdk-cpp")
- (version "1.8.159")
+ (version "1.9.92")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -932,7 +932,12 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(file-name (git-file-name name version))
(sha256
(base32
- "0jpfv9x82nq7hcix9in7qgrc8009dwpg6gr96hlgmcvqrqckd2r9"))))
+ "0nbq1qivykfg8jmrn8d0k6fcfa5dw9s90wnwddh7ia4zafmby7pd"))
+ (patches
+ (search-patches
+ "aws-sdk-cpp-cmake-prefix.patch"
+ "aws-sdk-cpp-disable-networking-tests.patch"
+ "aws-sdk-cpp-disable-werror.patch"))))
(build-system cmake-build-system)
(arguments
'(;; Tests are run during the build phase.
@@ -941,11 +946,9 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
'("-DBUILD_SHARED_LIBS=ON"
"-DBUILD_DEPS=OFF")))
(propagated-inputs
- `(("aws-c-common" ,aws-c-common)
- ("aws-c-event-stream" ,aws-c-event-stream)))
+ `(("aws-crt-cpp" ,aws-crt-cpp)))
(inputs
- `(("aws-checksums" ,aws-checksums)
- ("curl" ,curl)
+ `(("curl" ,curl)
("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "Amazon Web Services SDK for C++")