summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-07 14:19:44 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-07 14:21:28 +0100
commitf2089be3d179afc9b33ca62085c7a0566af7715e (patch)
treea5dffcf8ad8484d446545997e7dfb011bc4be9c8 /gnu/packages/cpp.scm
parentb509a071943d73f832a93af51d344785f49c5e8f (diff)
downloadguix-patches-f2089be3d179afc9b33ca62085c7a0566af7715e.tar
guix-patches-f2089be3d179afc9b33ca62085c7a0566af7715e.tar.gz
gnu: json-modern-cxx: Install json_fwd.hpp header.
* gnu/packages/cpp.scm (json-modern-cxx)[arguments]: Set JSON_MultipleHeaders=ON to install optional header.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..45d3faeafb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -334,7 +334,8 @@ as ordering relation.")
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- (list (string-append "-DJSON_TestDataDirectory="
+ (list "-DJSON_MultipleHeaders=ON" ; For json_fwd.hpp.
+ (string-append "-DJSON_TestDataDirectory="
(assoc-ref %build-inputs "json_test_data")))
#:phases (modify-phases %standard-phases
;; XXX: When tests are enabled, the install phase will cause