summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-05 17:09:28 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-06 09:43:08 +0200
commit86af6091d8ca1cc69ac12267d51544d50268e146 (patch)
treec322b607131a183cc6d9fd4684335fd109a935f1 /gnu/packages/cpp.scm
parent6900b3c1aa47ed2eb0a1cb2d69794fbab9a7346a (diff)
downloadguix-patches-86af6091d8ca1cc69ac12267d51544d50268e146.tar
guix-patches-86af6091d8ca1cc69ac12267d51544d50268e146.tar.gz
gnu: c++-gsl: Fix build with GCC 10.
* gnu/packages/cpp.scm (c++-gsl)[source]: Add a patch from Debian to fix compilation of a test. * gnu/packages/patches/c++-gsl-move-array-bounds-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 42e9d50687..af10d1186f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
@@ -127,7 +128,8 @@ range-v3 ranges are an abstraction layer on top of iterators.")
(git-file-name name version))
(patches
(search-patches
- "c++-gsl-find-system-gtest.patch"))
+ "c++-gsl-find-system-gtest.patch"
+ "c++-gsl-move-array-bounds-tests.patch"))
(sha256
(base32 "0gbvr48f03830g3154bjhw92b8ggmg6wwh5xyb8nppk9v6w752l0"))))
(build-system cmake-build-system)