summaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorArnaud Daby-Seesaram <ds-ac@nanein.fr>2024-06-18 11:08:44 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-26 15:16:43 +0100
commitb594c2b154b900a29855afc00a21306ab09a153d (patch)
treef5db6aaf38ea80911001ecb9fe8be8cd44dd0e08 /gnu/packages/coq.scm
parentda3e71f472c2335f56c3d07758715a514fdb3a9d (diff)
downloadguix-patches-b594c2b154b900a29855afc00a21306ab09a153d.tar
guix-patches-b594c2b154b900a29855afc00a21306ab09a153d.tar.gz
gnu: proof-general: Update to 4.5@cb23709a.
* gnu/packages/coq.scm (proof-general): Update to 4.5@cb23709a. Change-Id: Ieb33d8a0effa4c010d1f2488e166cd0647240180 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 7a8a49208a..4857426613 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -129,14 +129,14 @@ It is developed using Objective Caml and Camlp5.")
(list lablgtk3 ocaml-lablgtk3-sourceview3))))
(define-public proof-general
- ;; The latest release is from 2016 and there has been more than 450 commits
+ ;; The latest release is from 2022 and there has been more than 100 commits
;; since then.
- ;; Commit from 2021-11-25.
- (let ((commit "1b1083e86e0cddc20ff2f1a6b25c7a7eee2edf02")
+ ;; Commit from 2024-04-29.
+ (let ((commit "cb23709ad0c9a9ca0ee48b3ee73c29caea243b98")
(revision "1"))
(package
(name "proof-general")
- (version (git-version "4.4" revision commit))
+ (version (git-version "4.5" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -145,7 +145,7 @@ It is developed using Objective Caml and Camlp5.")
(file-name (git-file-name name version))
(sha256
(base32
- "1pnysczhscapgwmvf6ix7f31lf3hnh8h977bfll1m7jlxl9b9c0j"))))
+ "1spd8rz95s1x91i4lbbb6zabb8014fihx6ai6pgad1nwyr0y9bir"))))
(build-system gnu-build-system)
(native-inputs
`(("emacs" ,emacs-minimal)
@@ -170,6 +170,12 @@ It is developed using Objective Caml and Camlp5.")
(substitute* "Makefile"
(("\\(setq byte-compile-error-on-warn t\\)")
"(setq byte-compile-error-on-warn nil)"))))
+ (add-after 'unpack 'modify-readme-name
+ ;; The README file is called "README.md", but the Make variable
+ ;; "DOC_FILES" still refers to "README".
+ (lambda _
+ (substitute* "Makefile"
+ (("README") "README.md"))))
(add-after 'unpack 'patch-hardcoded-paths
(lambda _
(substitute* "Makefile"