summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2017-02-03 16:56:24 +0000
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-02-04 14:45:31 +0100
commit1ae60db842b13fb3057d78058757e649657f8980 (patch)
tree19ae897739e0620be6b5337491d5348ae3b8001f /gnu/packages/compression.scm
parent706998e73ad451368e443c94fe001ef0c64e08df (diff)
downloadguix-patches-1ae60db842b13fb3057d78058757e649657f8980.tar
guix-patches-1ae60db842b13fb3057d78058757e649657f8980.tar.gz
gnu: Add python-lz4.
* gnu/packages/compression.scm (python-lz4): New variable.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9ef255a42d..09dac4d7b0 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
@@ -45,6 +47,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages valgrind)
#:use-module (ice-9 match)
#:use-module ((srfi srfi-1) #:select (last)))
@@ -633,6 +636,31 @@ time for compression ratio.")
;; line interface programs (lz4, fullbench, fuzzer, datagen) are GPL2+.
(license (list license:bsd-2 license:gpl2+))))
+(define-public python-lz4
+ (package
+ (name "python-lz4")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lz4" version))
+ (sha256
+ (base32
+ "1irad4sq4hdr30fr53smvv3zzk4rddcf9b4jx19w8s9xsxhr1x3b"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/python-lz4/python-lz4")
+ (synopsis "LZ4 Bindings for Python")
+ (description
+ "This package provides python bindings for the lz4 compression library
+by Yann Collet. The project contains bindings for the LZ4 block format and
+the LZ4 frame format.")
+ (license license:bsd-3)))
+
+(define-public python2-lz4
+ (package-with-python2 python-lz4))
+
(define-public squashfs-tools
(package
(name "squashfs-tools")