summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-21 13:58:35 -0500
committerLeo Famulari <leo@famulari.name>2017-12-21 13:58:35 -0500
commitf76fc968669721e3baa6a0662da8e9e9f5da66cf (patch)
treeae58b84d89f144fbec974b7e75b24574f99b2e33 /gnu/packages/compression.scm
parent24ee3b28c6def91e4e41dd46441a029ab01b6d00 (diff)
parent5dc0e0b055ce2ab12c40066cee34511cd7a5cf03 (diff)
downloadguix-patches-f76fc968669721e3baa6a0662da8e9e9f5da66cf.tar
guix-patches-f76fc968669721e3baa6a0662da8e9e9f5da66cf.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index fc3aea31fe..37a934b5a2 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1602,7 +1602,7 @@ or junctions, and always follows hard links.")
(define-public zstd
(package
(name "zstd")
- (version "1.3.2")
+ (version "1.3.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/zstd/archive/v"
@@ -1610,7 +1610,7 @@ or junctions, and always follows hard links.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12krs9k5f408kyn0d7dwxqyc67177mgd14783ay10rafqsim8l5c"))))
+ "0yr91gwi380632w9y7p6idl72svq0mq0jajvdii05pp77qalfz57"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1618,7 +1618,13 @@ or junctions, and always follows hard links.")
(delete 'configure)) ; no configure script
#:make-flags
(list "CC=gcc"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ ;; Skip auto-detection of, and creating a dependency on, the build
+ ;; environment's ‘xz’ for what amounts to a dubious feature anyway.
+ "HAVE_LZMA=0"
+ ;; Not currently detected, but be explicit & avoid surprises later.
+ "HAVE_LZ4=0"
+ "HAVE_ZLIB=0")
#:test-target "test"))
(home-page "http://zstd.net/")
(synopsis "Zstandard real-time compression algorithm")