summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 20:59:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:26 +0300
commit848f550f2c105326dc3be4033c8aaf35ec21cde4 (patch)
treea16da3d588932ed175d9ca2e7023d79278f9dd00 /gnu/packages/commencement.scm
parent45953b1f67310110ffcfb3dc0aa87c7b6f1f76cf (diff)
downloadguix-patches-848f550f2c105326dc3be4033c8aaf35ec21cde4.tar
guix-patches-848f550f2c105326dc3be4033c8aaf35ec21cde4.tar.gz
gnu: Remove package/inherit from commencement.
This is a follow-up to several security grafts. * gnu/packages/commencement.scm (file-boot0, glibc-final, glibc-final-with-bootstrap-bash): Use '(package (inherit ...)' in place of '(package/inherit'.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 68faf36d52..d58c896971 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -113,7 +113,7 @@
(define file-boot0
(package-with-bootstrap-guile
- (package-with-explicit-inputs (package/inherit file
+ (package-with-explicit-inputs (package (inherit file)
(name "file-boot0"))
`(("make" ,gnu-make-boot0)
,@%bootstrap-inputs)
@@ -466,7 +466,7 @@ the bootstrap environment."
;; built just below; the only difference is that this one uses the
;; bootstrap Bash.
(package-with-bootstrap-guile
- (package/inherit glibc
+ (package (inherit glibc)
(name "glibc-intermediate")
(arguments
`(#:guile ,%bootstrap-guile
@@ -644,7 +644,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define glibc-final
;; The final glibc, which embeds the statically-linked Bash built above.
- (package/inherit glibc-final-with-bootstrap-bash
+ (package (inherit glibc-final-with-bootstrap-bash)
(name "glibc")
(inputs `(("static-bash" ,static-bash-for-glibc)
,@(alist-delete