summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
commitd726b954baaeff876ce9728e00920fa45f529f9a (patch)
tree4b767b7586a1082dd2691bc33c3e45ace044e6e5 /gnu/packages/commencement.scm
parent9a74a7db8626bc139307d115f5cec2648f5273ad (diff)
parente165a2492d73d37c8b95d6970d453b9d88911ee6 (diff)
downloadguix-patches-d726b954baaeff876ce9728e00920fa45f529f9a.tar
guix-patches-d726b954baaeff876ce9728e00920fa45f529f9a.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/ruby.scm
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 5ab4df612a..d38005a5ab 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -140,7 +141,7 @@ pure Scheme to Tar and decompression in one easy step.")
(name "gash-boot")
(source (origin
(inherit (package-source gash))
- (modules '())))
+ (snippet #f))) ;discard snippet for Guile 3.0 support
(arguments
`(#:implicit-inputs? #f
#:tests? #f
@@ -170,6 +171,10 @@ pure Scheme to Tar and decompression in one easy step.")
(package
(inherit gash-utils)
(name "gash-utils-boot")
+ (source (origin
+ (inherit (package-source gash-utils))
+ (patches '())
+ (snippet #f))) ;discard snippet for Guile 3.0 support
(arguments
`(#:implicit-inputs? #f
#:tests? #f
@@ -3818,14 +3823,17 @@ COREUTILS-FINAL vs. COREUTILS, etc."
'(#:modules ((guix build union))
#:builder (begin
(use-modules (ice-9 match)
+ (srfi srfi-1)
(srfi srfi-26)
(guix build union))
(let ((out (assoc-ref %outputs "out")))
-
- (match %build-inputs
- (((names . directories) ...)
- (union-build out directories)))
+ (union-build out
+ (filter-map (match-lambda
+ (("libc-debug" . _) #f)
+ (("libc-static" . _) #f)
+ ((_ . directory) directory))
+ %build-inputs))
(union-build (assoc-ref %outputs "debug")
(list (assoc-ref %build-inputs
@@ -3884,6 +3892,14 @@ binaries, plus debugging symbols in the @code{debug} output), and Binutils.")
(define-public gcc-toolchain-10
(make-gcc-toolchain gcc-10))
+(define-public gdc-toolchain-10
+ (package (inherit (make-gcc-toolchain gdc-10))
+ (synopsis "Complete GCC tool chain for D lang development")
+ (description "This package provides a complete GCC tool chain for
+D lang development to be installed in user profiles. This includes
+gdc, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
+
;; Provide the Fortran toolchain package only for the version of gfortran that
;; is used by Guix internally to build Fortran libraries, because combining
;; code compiled with different versions can cause problems.