summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorluhui <luhuins@163.com>2021-04-25 16:49:05 +0800
committerEfraim Flashner <efraim@flashner.co.il>2021-04-28 12:25:09 +0300
commit93242b54e4eff90432df9de4841297f19b358e55 (patch)
tree867bffc9afcda22bdc202f1d5ed1e28ee9fc7366 /gnu/packages/code.scm
parent5ea5ea60669a398c5c7eaf4cc23f1ec315eb3a3d (diff)
downloadguix-patches-93242b54e4eff90432df9de4841297f19b358e55.tar
guix-patches-93242b54e4eff90432df9de4841297f19b358e55.tar.gz
gnu: global: Fix globash.
* gnu/packages/code.scm (global)[arguments]: Add 'fix-globash phase. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index a79d8b4a2b..5518d5f5d2 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2021 lu hui <luhuins@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,6 +150,12 @@ highlighting your own code that seemed comprehensible when you wrote it.")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-globash
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((echo (string-append
+ (assoc-ref inputs "coreutils") "/bin/echo")))
+ (substitute* "globash/globash.in"
+ (("/bin/echo") echo)))))
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
;; Install the plugin files in the right place.