summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-08-31 19:23:54 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:41 -0400
commitc83c0a00937a5884ff79b0baa05804e9bed6e8b1 (patch)
tree6d4e1efd5c3b5152aa8ad2c2f434d59e79c1fbad /gnu/packages/chromium.scm
parent6548efcd739e8cd60843a2108aa7e01333b93038 (diff)
downloadguix-patches-c83c0a00937a5884ff79b0baa05804e9bed6e8b1.tar
guix-patches-c83c0a00937a5884ff79b0baa05804e9bed6e8b1.tar.gz
gnu: ungoogled-chromium-wayland: Use gexp.
* gnu/packages/chromium.scm (ungoogled-chromium-wayland): Use gexp. [arguments](builder): Use gexp. [inputs]: Rewrite inputs. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm68
1 files changed, 33 insertions, 35 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 6a9f113831..513e545938 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019-2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -966,42 +967,39 @@ testing.")
(name "ungoogled-chromium-wayland")
(native-inputs '())
(inputs
- `(("bash" ,bash-minimal)
- ("glibc-locales" ,glibc-utf8-locales)
- ("ungoogled-chromium" ,ungoogled-chromium)))
+ (list bash-minimal glibc-utf8-locales ungoogled-chromium))
(build-system trivial-build-system)
(arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((bash (assoc-ref %build-inputs "bash"))
- (chromium (assoc-ref %build-inputs "ungoogled-chromium"))
- (locales (assoc-ref %build-inputs "glibc-locales"))
- (out (assoc-ref %outputs "out"))
- (exe (string-append out "/bin/chromium")))
-
- ;; Use a Unicode locale so we can substitute the file below.
- (setenv "GUIX_LOCPATH" (string-append locales "/lib/locale"))
- (setlocale LC_ALL "en_US.utf8")
-
- (mkdir-p (dirname exe))
- (symlink (string-append chromium "/bin/chromedriver")
- (string-append out "/bin/chromedriver"))
-
- (call-with-output-file exe
- (lambda (port)
- (format port "#!~a
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(begin
+ (use-modules (guix build utils))
+ (let* ((bash #$(this-package-input "bash-minimal"))
+ (chromium #$(this-package-input "ungoogled-chromium"))
+ (locales #$(this-package-input "glibc-utf8-locales"))
+ (exe (string-append #$output "/bin/chromium")))
+
+ ;; Use a Unicode locale so we can substitute the file below.
+ (setenv "GUIX_LOCPATH" (string-append locales "/lib/locale"))
+ (setlocale LC_ALL "en_US.utf8")
+
+ (mkdir-p (dirname exe))
+ (symlink (string-append chromium "/bin/chromedriver")
+ (string-append #$output "/bin/chromedriver"))
+
+ (call-with-output-file exe
+ (lambda (port)
+ (format port "#!~a
exec ~a --enable-features=UseOzonePlatform --ozone-platform=wayland \
--enable-features=WebRTCPipeWireCapturer $@"
- (string-append bash "/bin/bash")
- (string-append chromium "/bin/chromium"))))
- (chmod exe #o555)
-
- ;; Provide the manual and .desktop file.
- (copy-recursively (string-append chromium "/share")
- (string-append out "/share"))
- (substitute* (string-append
- out "/share/applications/chromium.desktop")
- ((chromium) out))
- #t))))))
+ (string-append bash "/bin/bash")
+ (string-append chromium "/bin/chromium"))))
+ (chmod exe #o555)
+
+ ;; Provide the manual and .desktop file.
+ (copy-recursively (string-append chromium "/share")
+ (string-append #$output "/share"))
+ (substitute* (string-append
+ #$output "/share/applications/chromium.desktop")
+ ((chromium) #$output))))))))