summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorKristian Lein-Mathisen <kristianlein@gmail.com>2023-04-23 17:16:38 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-30 23:03:27 +0200
commit8bed4a85305ba1ee3bc1ed0d82ea1ec8135de4f4 (patch)
tree037c60afec2fd1bc4be23d8b2df37bc65191ff60 /gnu/packages/chicken.scm
parent14b2422cef6cbf47b4b79c23d1d9f68694cfb5a6 (diff)
downloadguix-patches-8bed4a85305ba1ee3bc1ed0d82ea1ec8135de4f4.tar
guix-patches-8bed4a85305ba1ee3bc1ed0d82ea1ec8135de4f4.tar.gz
gnu: Add chicken-compile-file.
* gnu/packages/chicken.scm (chicken-compile-file): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index b87b8118f1..782bca7427 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -77,6 +77,24 @@ produces portable and efficient C, supports almost all of the R5RS Scheme
language standard, and includes many enhancements and extensions.")
(license license:bsd-3)))
+(define-public chicken-compile-file
+ (package
+ (name "chicken-compile-file")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (egg-uri "compile-file" version))
+ (sha256
+ (base32
+ "1029i5ifr48vb3clvl8n50iq23rzc42szdcsl9320qmj1ksg9y93"))))
+ (build-system chicken-build-system)
+ (arguments `(#:egg-name "compile-file"))
+ (home-page "https://wiki.call-cc.org/egg/compile-file")
+ (synopsis "Programmatic compiler invocation")
+ (description "This egg provides a way to do on-the-fly compilation of
+source code and load it into the running process.")
+ (license license:bsd-3)))
+
(define-public chicken-srfi-1
(package
(name "chicken-srfi-1")