summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 12:51:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:47 +0200
commit7a18bd9e74b56a04ec7e4e120789e91d78830444 (patch)
tree2f245364b9bc842cd22adb37d792c99ba02b3a88 /gnu/packages/chez.scm
parentf37146969a2f24530fcdf270b2d19602809cb4ae (diff)
downloadguix-patches-7a18bd9e74b56a04ec7e4e120789e91d78830444.tar
guix-patches-7a18bd9e74b56a04ec7e4e120789e91d78830444.tar.gz
gnu: Rationalize texlive-updmap.cfg and texlive-tiny inputs.
TEXLIVE-UPDMAP.CFG and TEXLIVE-TINY should only be used as native inputs. Also remove texlive packages already provided by them. * doc/build.scm (pdf-manual): * gnu/packages/algebra.scm (pari-gp): * gnu/packages/bioinformatics.scm (discrover): (phyml): (velvet): * gnu/packages/chemistry.scm (yaehmop): * gnu/packages/chez.scm (stex-bootstrap): (chez-web): (chez-sockets): * gnu/packages/cran.scm (r-prereg): * gnu/packages/docbook.scm (dblatex): * gnu/packages/emacs-xyz.scm (emacs-auctex): * gnu/packages/engineering.scm (fastcap): * gnu/packages/fsf.scm (book-faif): * gnu/packages/graphviz.scm (dot2tex): * gnu/packages/maths.scm (hypre): * gnu/packages/ocaml.scm (unison): (ocaml-bibtex2html): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-nbconvert): (python-pypandoc): * gnu/packages/radio.scm (gnuradio): (libosmo-dsp): * gnu/packages/statistics.scm (r-with-tests): * gnu/packages/tex.scm (texlive-makecmds): (texlive-innerscript): (teximpatient): (texlive-xkeyval): Remove texlive packages already provided by TEXLIVE-UPDMAP.CFG. Don't add TEXLIVE-TINY or TEXLIVE-UPDMAP.CFG as inputs.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 86dd47d2ec..99c8dcac3a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -759,13 +759,7 @@ Chez Scheme.")))
;; though it would probably be easy to add.
(propagated-inputs
(list xorg-rgb
- (texlive-updmap.cfg
- (list texlive-bibtex
- texlive-ec
- texlive-epsf
- texlive-hyperref
- texlive-l3backend
- texlive-oberdiek))
+ (texlive-updmap.cfg (list texlive-epsf))
ghostscript
netpbm))
;; Debian uses a versionless path for STEXLIB,
@@ -1018,14 +1012,8 @@ create compilers, making them easier to understand and maintain.")
;; mktexpk: don't know how to create bitmap font for bchr8r
;; Replacing the following with `texlive` fixes it.
;; What is missing?
- (texlive-updmap.cfg (list texlive-oberdiek
- texlive-epsf
- texlive-metapost
- texlive-charter
- texlive-pdftex
- texlive-context
- texlive-cm
- texlive-plain))))
+ (texlive-updmap.cfg
+ (list texlive-context texlive-epsf texlive-metapost))))
(arguments
(list
#:make-flags
@@ -1079,7 +1067,7 @@ programming in Scheme.")
(native-inputs
(list (chez-scheme-for-system)
chez-web
- (texlive-updmap.cfg (list texlive-pdftex))))
+ texlive-tiny))
(arguments
(list
#:tests? #f ; no tests