summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-13 17:05:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-13 22:49:55 +0200
commit9003bd8709c2b3f88e4ab34d3fc8e061a1beb08e (patch)
treeb67c6cb2cc723dfe9094f532dfa5589c2d7e9cf6 /gnu/packages/chez.scm
parente47e9d927368dac0d6a3c528ce350cf4c73c1a28 (diff)
downloadguix-patches-9003bd8709c2b3f88e4ab34d3fc8e061a1beb08e.tar
guix-patches-9003bd8709c2b3f88e4ab34d3fc8e061a1beb08e.tar.gz
gnu: Add texlive-pdftex.
* gnu/packages/chez.scm (texlive-pdftex): New variable. (texlive-generic-pdftex): Deprecate in favor of texlive-pdftex. (teximpatient)[native-inputs]: Replace texlive-generic-pdftex with texlive-pdftex. (texlive-latex-pdfx)[propagated-inputs]: Same. * gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]: Same. (python-matplotlib-documentation)[native-inputs]: Same. (python-ipython-documentation)[native-inputs]: Same. * gnu/packages/chez.scm (chez-web)[native-inputs]: Same. (chez-sockets)[native-inputs]: Same.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 1cd2cde71b..adc2f1976e 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -320,9 +320,9 @@ and 32-bit PowerPC architectures.")
texlive-generic-epsf
texlive-metapost
texlive-fonts-charter
- texlive-generic-pdftex
texlive-context-base
texlive-fonts-cm
+ texlive-pdftex
texlive-tex-plain)))))
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
@@ -381,7 +381,7 @@ programming in Scheme.")
(native-inputs
`(("chez-scheme" ,chez-scheme)
("chez-web" ,chez-web)
- ("texlive" ,(texlive-union (list texlive-generic-pdftex)))))
+ ("texlive" ,(texlive-union (list texlive-pdftex)))))
(arguments
`(#:tests? #f ; no tests
#:phases